Home | 简体中文 | 繁体中文 | 杂文 | 打赏(Donations) | ITEYE 博客 | OSChina 博客 | Facebook | Linkedin | 知乎专栏 | Search | Email

第 12 章 Switch

目录

12.1. 交换机初始化
12.1.1. 密码设置
12.1.2. 域名,网管
12.1.3. Telnet
12.1.3.1. privilege level
12.1.4. 保存当前配置
12.1.5. 恢复交换机出厂值
12.2. interface
12.2.1. show interfaces status
12.2.2. ip address
12.2.3. 配置端口速率及双工模式
12.2.4. range
12.2.5. 端口隔离
12.3. DHCP
12.3.1. Gateway
12.3.2. snooping
12.3.3. DHCP中继代理
12.4. Route port
12.5. 交换机端口镜像配置
12.6. Ethernet Port Groups
12.6.1. LACP
12.6.2. desirable
12.7. VLAN
12.7.1. vlan database
12.7.2. 两层Switch配置讲解
12.7.3. 3 Layer Switch
12.7.4. VTP
12.7.4.1. Configuring a VTP Server
12.7.4.2. Configuring a VTP Client
12.7.4.3. example for vtp
12.8. ACL
12.9. 流量控制
12.9.1. 粗糙的流量限制
12.9.2. bandwidth
12.9.3. priority
12.10. stack-manager
12.11. HSRP(Hot Standby Router Protocol)
12.12. CDP (Cisco Discovery Protocol)
12.12.1. clear cdp counters
12.12.2. show cdp
12.12.3. show cdp entry
12.12.4. show cdp interface
12.12.5. show cdp neighbors
12.13. 4506/4507 专有命令
12.13.1. 用户认证
12.13.2. PoE
12.13.3. show module
12.14. Switch Config Example
12.14.1. VLan Router
12.14.1.1. VLAN间DHCP
12.14.1.2. 多vlan与vlan间路由,并且每个vlan配合一个DHCP池,所有vlan均能访问internet
12.14.2. VLAN下联Switch
12.14.3. LAN to LAN
12.14.4. Cisco 2811 Router + 2960 Switch
12.14.4.1. running-config
12.14.5. Cisco Catalyst 3750 series DHCP + VLAN + Routing Example
12.14.6. Cisco Catalyst 3750 + Cisco Catalyst 2960 VTP Example
12.14.6.1. VTP Server
12.14.6.2. VTP Client
12.14.6.3. Cisco Config File

Cisco 固定配置交换机命名规则

对于Cisco的固定配置的交换机,一般有3750,3550,3560,2960,2970这几个系列。

它们在型号命令上有自己相应的规则,特总结如下:

eg: WS-C3750G-48TS-S

C3750表明这款产品属于3750这个系列,也就是产品的型号。

G----表明其所有接口都是支持千兆或以上,如果没有这个就表明其主要端口都是10/100M的或者100M的

48----表明其拥有主要的端口数量为48个

T----表明其主要端口是电口(也就是所谓的Twirst Pair的端口

P----表明其主要端口是电口,同时支持PoE以太网供电

S----表明其带的扩展的接口为SFP类型的接口

最后部分的-S表明交换机带的软件是SMI标准影像的,-E表明是EMI影像的
	

12.1. 交换机初始化

Cisco Catalyst 2960 Series Switches

		
Press RETURN to get started!


*Mar  1 00:00:25.073: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, cha                                                                                                 nged state to down
*Mar  1 00:00:26.189: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for typ                                                                                                 e vlan
*Mar  1 00:00:47.102: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(44)SE6, REL                                                                                                 EASE SOFTWARE (fc1)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 09-Mar-09 18:10 by gereddy


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:
Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

  Enter host name [Switch]:

  The enable secret is a password used to protect access to
  privileged EXEC and configuration modes. This password, after
  entered, becomes encrypted in the configuration.
  Enter enable secret: chen

  The enable password is used when you do not specify an
  enable secret password, with some older software versions, and
  some boot images.
  Enter enable password: chen
% Please choose a password that is different from the enable secret
  Enter enable password: chen

  The virtual terminal password is used to protect
  access to the router over a network interface.
  Enter virtual terminal password: chen
  Configure SNMP Network Management? [no]: yes
    Community string [public]:

Current interface summary

Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  up                    down
FastEthernet0/1        unassigned      YES unset  down                  down
FastEthernet0/2        unassigned      YES unset  down                  down
FastEthernet0/3        unassigned      YES unset  down                  down
FastEthernet0/4        unassigned      YES unset  down                  down
FastEthernet0/5        unassigned      YES unset  down                  down
FastEthernet0/6        unassigned      YES unset  down                  down
FastEthernet0/7        unassigned      YES unset  down                  down
FastEthernet0/8        unassigned      YES unset  down                  down
FastEthernet0/9        unassigned      YES unset  down                  down
FastEthernet0/10       unassigned      YES unset  down                  down
FastEthernet0/11       unassigned      YES unset  down                  down
FastEthernet0/12       unassigned      YES unset  down                  down
FastEthernet0/13       unassigned      YES unset  down                  down
FastEthernet0/14       unassigned      YES unset  down                  down
FastEthernet0/15       unassigned      YES unset  down                  down
FastEthernet0/16       unassigned      YES unset  down                  down
FastEthernet0/17       unassigned      YES unset  down                  down
FastEthernet0/18       unassigned      YES unset  down                  down
FastEthernet0/19       unassigned      YES unset  down                  down
FastEthernet0/20       unassigned      YES unset  down                  down
FastEthernet0/21       unassigned      YES unset  down                  down
FastEthernet0/22       unassigned      YES unset  down                  down
FastEthernet0/23       unassigned      YES unset  down                  down
FastEthernet0/24       unassigned      YES unset  down                  down
GigabitEthernet0/1     unassigned      YES unset  down                  down
GigabitEthernet0/2     unassigned      YES unset  down                  down

Enter interface name used to connect to the
management network from the above interface summary: FastEthernet0/24

Configuring interface FastEthernet0/24:
  Configure IP on this interface? [no]: yes
    IP address for this interface: 172.16.0.253
    Subnet mask for this interface [255.255.0.0] :
    Class B network is 172.16.0.0, 16 subnet bits; mask is /16
Would you like to enable as a cluster command switch? [yes/no]: yes
Enter cluster name: cl1

The following configuration command script was created:

hostname Switch
enable secret 5 $1$W1RW$ZdWR.sS/g2RwJMv4F5sRq0
enable password chen
line vty 0 15
password chen
snmp-server community public
!
!
interface Vlan1
shutdown
no ip address
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
 --More--

		
		

12.1.1. 密码设置

基本操作

Switch command
Switch > en 进入特权模式
Switch # conf t 进入全局配置模式
Switch(config)# interface interface-num 进入接口
Switch(config)# hostname name 给交换机命名
Switch(config)# enable password password 设置明文密码
Switch(config)# enable secret password 设置加密的启用秘密口令。如果设置则取代明文口令
Switch # copy running-config startup-config
Switch # write 保存设置
			

12.1.2. 域名,网管

初始化设置

Switch setup
switch(config)# ip default-gateway ip-address
switch(config)# ip domain-name domain-name
switch(config)# ip name-server IP-address 交换机上设置远程访问,用于交换机管理
			

12.1.3. Telnet

通过Telnet进入命令行接口

Switch>enable
Switch#conf t
Switch(config)#line vty 0 4
Switch(config-line)#login
Switch(config-line)#password cisco
			

12.1.3.1. privilege level

line vty 5 15
 privilege level 15
 password neo
 login
!
				

12.1.4. 保存当前配置

Save

Switch#wr
Building configuration...
[OK]
			

12.1.5. 恢复交换机出厂值

Switch# erase startup-config